SIE 509 – Principles of GIS
Exercise 3:  Working with A Geodatabase
Due:     10/12/17                                                                                    
Total Points:  50
Introduction:

This exercise introduces you to the personal geodatabase and the feature data set.  You will then work with the tables within your geodatabase.   You will perform some of the most common tasks done on tables, including formatting, editing, and using the field calculator and field statistics functions.  

Procedures:

Setup

1. Download the Ex_03 folder.
2. Open ArcCatalog and connect to the Ex_03 folder.
3. In the Catalog Tree, right-click on your Ex_03 folder and select New > Personal Geodatabase and name it Ex_03 (if you move to quickly, you may have to right-click and choose Rename).
4. Right-click on your geodatabase and choose New > Feature Dataset and name it US_States,.
a.
Click Next, and set the coordinate system;:  Select Projected > Continental > North America > US Contiguous Albers 
Equal Area.

b.
Click Next and accept the defaults for all other parameters.
c.
Click Finish.

At this point your geodatabase is empty, you will need to import the shapefiles into your Feature Dataset.

5. Right-click on your Feature Datasest and select >Import > Feature Class (multiple) and import the following shapefiles into your feature dataset: Cities.shp, and Cong_Districts.shp, Quake_Hist,shp, and States.shp.  (You can add them all at once by holding down the Control key.
NOTE:  You can also drag and drop from the Catalog Tree to the dialog box.

6. When importing is complete (it may take a minute), delete the four shapefiles from your folder and close ArcCatalog.

7. Launch ArcMap and open the Ex_03.mdx saved in your folder.   
Notice that nothing is displayed, and that each of the layers in the TOC have a red exclamation mark to its left.  This is telling you that ArcMap could not find the data that goes with this mxd file.  We will correct this is shortly.
8. Set the current workspace and your scratch space (Geoprocessing > Environments) to your Feature Dataset.

9. Right-click on US Major Cities in the TOC and select Data > Repair Data Source.
a.
Navigate to your files in your Feature Dataset and select cities.
b.
Click Add.

Since all of those files were in the same location, they should all repaired.  If not repeat with the next file.

10. Save your project and give it a name.
Organizing Commands on a Toolbar

Although ArcMap comes with many toolbars, you may want a toolbar that organizes commands that you often use together.  When you create a custom toolbar, it will save with the current map document.  If you want to save it so that it will open in all map documents, uncheck the “Create New Toolbars and Menus in the Document” check box on the Options tab of the on the Customize dialog box. (ArcGIS Desktop Help)
11. From the File Menu, Click Customize > Customize Mode.

12. Verify that the Toolbars tab is active and click New.
13. Replace the toolbar name with Data Viewer and click OK.  A new, empty toolbar appears just above your Table of Contents, and the Data Viewer is added to the list of toolbars in the Customize dialog box.  The new toolbar will expand as you add commands to it.

14. With the Customize dialog box open, drag Find from the Tools toolbar to the Data Viewer toolbar.  Find is no longer on the Tools toolbar, because moving a command from one toolbar to another doesn’t make a copy of it.

15. Click on the Commands tab of your Customize dialog box.  The Commands tab displays two lists, Categories and Commands.  Categories organizes commands by their functionality.  The Commands list contains commands that you drag onto toolbars.  Unlike dragging from one toolbar to another, commands remain in the Commands list, so you can drag as many copies to as many toolbars as you wish.

16. In the Categories list, scroll down and click Pan/Zoom.

17. From the Commands list, drag Full Extent to the Data Viewer toolbar.

18. Add the Zoom In and Pan commands to your Data Viewer toolbar as well.

19. In the Categories list, click View and drag the Data View command to your toolbar.

20. Repeat with the Layout View command.

21. Right-click on the Data View tool and select Text only.

22. Repeat with the Layout View.

23. Right-click Data View and select Begin a group.  

24. In the Categories list, click File.  From the Commands list, drag Print to your toolbar, then right-click on it and select Begin a Group.

25. Close the Customize dialog box.
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26. Drag your new toolbar to an area of the screen where it is easily viewed, screen print it and paste a copy into your Report Sheet.

27. Verify that the US Major Cities and the US States are checked.

28. Verify that the 114th Congressional Districts is unchecked so that the US States layer is visible.

29. Right-click on the US States layer and choose Label Features from the context menu.

30. Test your new toolbar to:

a. Find Manhattan (the city/town) in the Visible layers.
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b. Right-click on Manhattan to use the Zoom to feature property.

c. Right-click on Manhattan to use the Flash property.

d. Return to the full extent.

Q1.  In what state did you find Manhattan?

31. Re-check the districts layer.
Changing the Appearance of a Table:   

32. First we will change the order of the fields in the US States table.
a. Open the Properties dialog box, by right-clicking on the layer name.
b. Click on the Fields tab.
c. Move FIPS, POP_1990, POP_2000 and POP_2010 to the top.
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33. Then rearrange them as follows:
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There are usually several ways of accomplishing a task in ArcMap.  In the Properties dialog box you can “hide” fields by unchecking them, you can change the display name of a field by giving it an alias and you can change the number format, but we can also do those tasks from within a table.

34. Click OK to close the dialog box and open the US States attribute table.
35. Notice how the STATE_NAME field is much wider than the data contained in it.  Narrow the fields to a more suitable width by clicking and dragging the right border of the field.  You can also adjust the width of a field to the minimum required by double clicking on the right border.
36. Since the STATE_FIPS field is not very useful, so we will hide it.  Right-click the field name and choose Turn Off from the context menu.
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37. The STATE_ABBR field is also too wide for its data, but narrowing it will cut off the field name.   
a. Right-click the field name and choose Properites.  Give it an alias ABBR.

b. Click OK

38. Change the STATE_NAME field to NAME

39. Scroll over to the right of the table and look at the different fields of population data from the U.S. Census.  In a large table, it may be difficult to match the values to the right state, because the state names scroll quickly out of sight.

a. Freeze the NAME column by right-clicking on the Name field and choose Freeze/Unfreeze Column.

b. Now scroll again and see how much easier it is to interpret the data.

NOTE:  An unfrozen column will not return to its original position.  To move it back, you will have to remove the feature from the map document, then re-add it.

40. Next you will use the Sort function to obtain information about the states with the largest and smallest populations.  Right-click on the POP2010 field name and choose Sort Descending.

Q2.  Which state has the largest population?
Q3.  Which state has the smallest population?
41. Notice that the Shape_Area field has decimal values in it, which make it hard to compare the sizes of different states.  To reformat the field so that no decimals are displayed:

a. Right-click on the field name and choose Properties from the context menu.

b. Click on the ellipses to the right of the word numeric.
c. Change the number of decimal places to 0.
Q4.  Which state is closest in area to Maine?
Using Queries on Tables:

42. Next you will use the Select by Attributes function to select states with a 2010 population of over 5 million.

a. [image: image6.png]Rilatefts you assaciate data with s aper, The associated deta it
sppenced nto this layer's attibute tabe ke it i in a Join. Instead you
can sccess the related data when you work with ths layers atibutes or

Establsting a relate is paticulary useful f there is 2 -to-many or
many-o-many associstion between the layer and the elated data.

1. Choose the fiekd in this ayer that the reste wil be based o

ABER

2. Choose the table orlayer o relate to tislaye, o load from

& 106t Congress Districts

3. Choase the fiekd n te related table o ayer to base the relate or:

STATE_ABBR

4. Choase a pame for the relat:

[CongreeDistricts|

About Relting Daa |




With the attribute table still open, click the Table Options button drop down arrow and choose Select By Attributes.

b. Enter the Query [POP2010] >5000000.   Click Apply.  

c. Click on the Show Selected button to view only the selected records.

Q5.  How many states were selected?
43. Clear the selected set by clicking the Options button on the table and choosing Clear Selection from the context menu.  If the Clear Selection choice is not available, verify that the Show All button is clicked.
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Create the following query:  [POP2010] > [POP2000] AND [POP2000] > [POP1990] then switch the selection:
Q6.  Which states are now selected?
45. Create the following query: [SUB_REGION] = 'East North Central' AND [SUB_REGION] = 'East South Central'
Q7.  How many states were selected? 
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46. Clear the selection by using the Clear Selection icon.

47. Change the AND to OR.

Q8.  Now many states were selected?
Think about why you should use an OR in this situation.  It’s important!
48. Clear the selected.
Calculating Statistics for Fields:

49. To calculate and view some population statistics for states:

a. Right-click on the POP2010 field name and choose Statistics from the context menu.

b. Spend some time looking at the results.

Q9.  How many people live in all of the states?
50. Use the drop-down list in the Statistics box to select the POP2000 field.

Q10.
Did the average number of people in a state increase, decrease, or stay the same from 2000 to 2010?
51. Close the Statistics box.

NOTE:  The frequency diagram cannot be placed directly into a layout as a graph.  You can do a screen capture then paste it into Paint or some other image processing software and save it as a jpg file.  A jpg file can be placed in a layout.

52. The Statistics command calculates using all of the records in a table, unless a subset of records has been selected, then only the selected set is used in the calculation.

a. Use the Select By Attributes option to select all states with a 2010 population greater than 5 million.

b. Now open the Statistics box again and note that the count is smaller.

c. Clear the selected features.

53. Close the States Table and uncheck it in the TOC.

54. Open the table for the 114th Congress District by right-clicking on the layer name and choosing Open Attribute Table. Examine the fields.

Notice that the congress person’s party affiliation is listed after his/her name in the NAME field.  You would like to make a map showing the distribution of the two parties across the nation, but you cannot do it with the affiliation combined with the name.
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With the table open, click the Options button and choose Add New Field from the menu.

a. Type in the field name PARTY, choose Text as the field type, and a Length of 1.  Click OK.  A new column is added to the table.
b. A new field is created and filled with <Null>.

56. Next you will create a query to select all of the Democratic congress people.

a. Click on the Options button and choose Select By Attributes.

b. Verify that the Method is set to Create a new selection.

c. Double-click on NAME.

a. Single-click on Like.

b. Select the appropriate buttons, but you will need to type in the single quotes
[NAME] LIKE '*(D)*'
c. Click OK and open the attribute table.  Notice that all of the Democrats have been selected.

Note:  Like is an operator that searches for matching subsets of characters in a field.  The * symbol is a “wildcard” that can replace one or more characters.  Since the parentheses are part of the expression (D) the search will ignore a D that is part of a name.

57. Now right-click on the PARTY field and choose Field Calculator from the context menu.  

a. A warning message will appear. Click Yes to continue.

b. In the Field Calculator dialog box type “D” in the expression box.  Be sure to type in the double quotes. (See the Figure on the next page). Click OK.

TIP:  You use single quotes in a query (selection) and double quotes in a calculation.
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c. Clear the selection.

d. Repeat the process to place an R in the Party field for all Republicans.

e. Close the Attribute table.

58. Now that the fields are all calculated, you can create a map showing which districts are Republican and which are Democratic.

a. Right-click on the 114th Congress Districts layer, select Properties from the menu, and click the symbology tab.
b. Set the Value field to PARTY.

c. In the Show column choose Categories->Unique Values.

d. Click the Add All Values button.

Notice that there are three categories.  One congressional seat is vacant, the other is held by an Independent.  You are only interested in the Democrats and Republicans.

e. Select the <Null> category and click the Remove button.

f. Double-click on the Democratic symbol and make it blue.

g. Double-click on the Republican symbol and make it red.

h. Uncheck the <all other values> category.

i. Click OK.
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59. Select the Labels tab.  Label all features the same way, using STATE_NAME, try a size 10 font.

60. For Placement properties choose “Try horizontal first then straight.

61. If you are unable to view completed map, verify that 114th Congress Districts is checked in the Table of Contents.
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Summarizing Tables

We can use the Summarize feature to determine the number of Congress Districts in each state, as it counts the number of features in each group.

62. Open the 1114th Congress Districts attribute table.

a. Right-click on the STATE_ABBR field and choose Summarize.

b. Name the output file dists_per_state, and be sure that it is being saved in your Ex_03 geodatabase.

c. Click OK.

d. Click Yes when asked if you want to add the table to the map.

e. The table should now appear in the Table of Contents.
f. Close the 114th Congress Districts attribute table.  

63. The newly created table has been added as a standalone table; i.e., not an attribute table, to the Table of Contents.  If you do not see it listed, click on the Source tab at the bottom of the Table of Contents.  Right-click on the new table and select Open to view its contents.

Q11.  How many districts does New York have?
Note:  Standalone tables cannot be displayed on a map.  Only data contained in a layer’s attribute table can be displayed.

In other cases, instead of simply finding out the number of objects in a group, the goal is to generate some statistics about each group.   

64. To observe this type of summarize in action, you will determine the total deaths and damage, and average magnitude of earthquakes in each state.

a. Open the attribute table and examine the fields, noting the state abbreviation field and the fields for deaths, damage and magnitude (MAG).

b. Since you need to summarize the earthquakes by state, Right-Click on the STATE field and choose Summarize from the context menu.

i. Verify that the field to summarize is set to STATE.

ii. Locate the DAMAGE field in the list, expand if necessary, and choose Sum as the statistic to calculate.

iii. Calculate the Sum for the DEATHS field.

iv. Calculate the Average of the MAG field.

v. Enter the location and the name of the output table, calling it quakesum.dbf and saving it to your Ex_03 folder.

vi. Say yeas when asked to add it to the map.

65. Right-click on the quakesum table to open it.

a. Examine the table.

b. Sort the Sum_DEATHS field in descending order.

Q12.  Which state has the most deaths caused by earthquakes?
c. Close the quakesum table.

d. Click on the Display tab at the bottom of the table of contents.

e. Turnoff the Quake_Hist layer  and the 114th layer before going on.

Joining Tables - To join a separate table to a theme attribute table, the relationship must be 1:1 or M:1 with the theme attribute table.  

It would be helpful if the information in your dist_per_state table was actually contained in the attribute table, so it could be displayed.  Joining it to the US STATES attribute table using the common field containing the state’s abbreviation solves the problem.

66. Right-click on the US STATES layer and choose Joins and Relates->Join.

a. In the Join dialog box, enter Join Attributes from a Table in the dropdown box.

b. Choose ABBR as the field in the US STATES to base the join on.

c. Choose dists_per_state as the table to join.

d. Choose STATE_ABBR again as the field in the source table to join on.

e. Select Keep all records.

f. Click OK to finish the join.

g. Click No to indexing the join field.

h. Open the US States table and scroll to the end to find the new fields that have been added as a result of the join.
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Q13.
What is the relationship between the theme attribute table and the dist_per_state table?

Note:  In a joined table, the fields are prefixed with the name of the table from which they came.  This is helpful, especially if the tables had columns with the same or similar names.

67. You can make the table easier to read.

a. Open the Field Properties sheet of the US_STATES layer.

b. Hide the OID and ABBR fields as you don’t need them.

c. Give the Count_ABBR the alias CONGRESS_DISTRICTS which is a more descriptive name.

d. Close the US States table.

68. Create a graduated color map showing the number of representatives for each state and export it as a jpeg.
Note:  In a single data frame, only a single map layout exists at any point in time.  If you wish to have multiple maps on a layout, you need to have a different data frame for each map.

Relating Tables:  If a join is not possible; i.e. the relationship is 1:M or M:M then a relate must be used.  In a relate, information may be accessed from both tables, but they are not physically connected.
69. Next you will obtain information on which representatives come from which subregions of the country, as they would presumably have similar issues to confront with their constituencies.  However, the SUB_REGIONS field is in the US States table, not the districts tables so you will need to set up a relationship between the US States tables and the 114th Congress Districts.

a. Right-click on the US States layer and choose Joins and Relates->Relate

b. The relate will be based on the ABBR field.

c. The 114th Congress Districts is the table to relate.

d. This table will also use the ABBR field.

e. Name the relate CongressDistricts.

f. Click OK.
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g. Open the US States table and the 114h Congress Districts table.  You can toggle back and forth between the two tables by clicking on the buttons in the lower left corner.  A better option though is to arrange the tables so that both are visible
h. From the States option button select Arrange Tables > New Vertical Table Grou, the tables should now appear side-by-side.
i. Click the options button on the States table and choose Select By Attributes.
j. Enter a query to select all the states in the New England (N Eng) sub_region.
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Now that the New England states are selected, the relate gives easy access to the representatives from these states.  To view the relate information select the Related Tables icon in the Cong_Districts table. The related records in the 114th Congress Districts table are now also selected.
Q14.
How many representatives come from New England states?

71. Clear the selected features.

72. Remove the Relates and Joins by right-clicking on the States layer and choosing Joins and Relates->Remove Join(s)->Remove All Joins.

73. Then remove all relates.

Note:  It is possible to export the selected records as a .dbf file, which can then be opened in MS Excel®.  If you wish to try this, click the Options button and choose Export, and give it a name.

Analyzing Tabular Data

As a final exercise, you will explore the percentage of Native Americans () by state.

74. Open the States attribute table.

a. From the Options buttom choose Add a new field called perc_NatAm and select Float as its type

b. Click OK.

c. Set the precision to 4 and scale as 1.

75. Next you will calculate the percentage of Native Americans (Ameri_Es for American Indian and Eskimo – not exactly politically correct).

a. Right-click on the perc_NatAm field and choose Field Calculator from the context menu.

b. Enter the expression by selecting the appropriate symbols from the wizard (Ameri_es)/(POP2010)*100 and click OK.

Note:  If all of the records equal 0, you might have accidentally selected a single record.  If records are selected, then they are the only ones that get calculated.  If so, choose Options-> Clear Selection from the table and try again.

76. Create a map showing the percentage of Native Americans by state.

77. Next you will gather some information about the Native Americans in different sub-regions.

a. Right click on the SUB_REGION field and choose Summarize.

b. Choose Sum for the statistic and Perc_NatAm as the field.

c. Enter the name SubRegNA.dbf for the table to be produced and be sure that it is being saved in your workspace.

d. Add the table to your map document.

e. Close the US States table.

f. Open the new table.

Q15.  Which sub-region has the largest percentage of Native Americans?
78. Insert a new data frame and add the States file.

79. Create percentage fields for white, black, Hispanic and other ( [ASIAN] + [HAWN_PI] + [OTHER] + [MULT_RACE]) / [POP2010]*100 
80. Select Properties Symbology >Charts > Pie, and select all of your percent fields.  Label the states.

81. Create an attractive Layout with your two maps.
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Deliverables:

Submit your Report Sheet with your screen print of your data viewer (4 Points) and the answers to your 15 questions( 2 Points Each)  and your layout with 2 maps (8 Points Each).  Your maps require a title, and a legend
