Exercise 1: An Overview of ArcMap and ArcCatalog

Introduction:

“ArcGIS is an integrated collection of GIS software products for building a complete GIS. ArcGIS
enables users to deploy GIS functionality wherever it is needed—in desktops, servers, or
custom applications; over the Web; or in the field.” Desktop ArcGIS consists of two major
components: ArcMap, which allows you to display and analyze spatial data, and ArcCatalog
which allows you to manage your files.

The following exercise provides step-by-step instructions for doing basic tasks and solving
simple problems in ArcGIS.

Life with ArcGIS is simpler if you keep all of your data files in one folder. | strongly recommend
that you use a flash drive and create a COS120 folder on the drive, and under that a folder for
each exercise and one for each two-week assignment.

Flash drive
C0S120
Exercise 1
Exercise 2
etc.

Questions will appear throughout the lab. These are intended to make you think about
something important.

Procedures:

Think of ArcCatalog as a window explorer. In ArcCatalog, you can browse, organize, distribute,
and document your GIS data. ArcCatalog resembles Microsoft Windows Explorer but is
designed for viewing geographic databases, maps, and metadata.

1. Download and extract the data for Exercise 1 from the class website
(http://umaine.edu/computingcoursesonline/cos120/).

2. From the Start menu, select Programs->ArcGIS->ArcCatalog 10

The ArcCatalog window pops up. The window is divided into two parts. The left part is the
catalog tree, and lists the connections you can make. The right hand side has three tabs,
Contents, Preview, Description.
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Connect to a Folder:

3. Find the Connect to Folder icon on the toolbar at the top. Click on this button to ;-'7'!'|
connect to a folder. Navigate to your COS120, Ex_1 folder and click OK in the small
pop up window
[ %) ArcCatalog - ArcInfo - CAUsers\Connie\Documents\Connie' Docs\SIES09 G=RE=)
File Edit View Go Geoprocessing Customize Windows Help
&8 & x BEER QEBBO Fr?iwc 2
\
Up one level Disconnect folder
Connect to
folder
3. The contents of the Ex_1 folder are displayed in the panel on the right. You can select
any item here to see more information about the dataset or the content of the folder on
the right side of the window, by selecting a file in the Catalog Tree and the different tabs
in the right-hand panel. The information may not be complete for all files, an issue that
will be addressed later in the course.
4,

Explore the Ex_01 dataset, and look at the symbology in the right window. There are
a. ArcInfo coverages (note the folders), - hospitals
b. a grid file (a raster data set) & bangor_ard

c. adbf(database) file, and (] grade_vl.dbf

.78 schoals.shp ?



d. shapefiles.

Note the different icons for the different file types.

ArcInfo coverage are a proprietary file type, and are composed
of several folders, each containing multiple files. Bocks 2000
and waterbodies are polygon files, streets is a line file and
hospitals is a point file.

Shapefiles are a generic file type and consists of a minimum of
three files, each having the same filename with a different
extension. The three required extensions are: .shp (stores the
geometry), .shx (a spatial index file) and .dbf. (stores the
attribute tables). Penobscot_Towns and the Penobscot_River
are polygon files, rails is a line file and schools is a point file

P blacks_2000
5 hospitals
streets

S waterbodies

Penobscot_MCD.shp
Penobscot_River.shp
rails.shp

&4 schools.shp

Click on the + sign next to the blocks2000 layer. This Arcinfo coverage is composed of
an arc file (line), a label file, a polygon file and a tic file (point). All coverages are
composed of multiple files, and should only be manipulated (copied, moved or

renamed) in ArcCatalog.

Next select the schools layer.

a. Verify that the Contents tab is active. This window displays the name of the

feature, its type and thumbnail if it exists.

b. Click the Preview tab. The Preview window lets you preview the data set. If the
drop down box at the bottom of the right-panel is set to Geography, you will
preview the map file. Ifitis set to Table, you will preview the attributes of the

file.
c. Now click on the Description tab.

Click on the Edit icon

Upgrade port

schools
Shapelile



This allows you to create or alter the description. When creating a GIS project, you should
enter all of the required information, to ensure the usefulness of the project over time.

8. Preview the geography of a polygon, a line and a point file type.

Manage data with ArcCatalog:

ArcCatalog allows you to perform data management tasks such as creating new folders and
doing copy and paste operations, as well as renaming files. Although you can perform these
operations on shapefiles using Windows Explorer, coverages and geodatabases cannot be
managed outside of ArcCatalog..

1. Right-click on the Ex_01 folder in your documents folder.
2. Right-click on Penobscot_MCD (minor civil divisions) and choose Rename. Rename it as
Penobscot_Towns.

Introducing ArcMap:
ArcMap is the main application for data display, data query, and data output. You can
work with ArcCatalog and ArcMap together for moving data from ArcCatalog. You can Q

launch ArcMap from the Start menu, or from the Launch ArcMap button in r.ﬂ
ArcCatalog. You can also launch ArcCatalog from within ArcMap )

1. Launch ArcMap and choose “A new empty map” from the dialog box and click OK. This will
display the interface of the ArcMap application. At the top part of the window is a menu
bar and two toolbars. At the lower part, ArcMap comes with two parts on the screen the
Table of Contents (TOC) at left and the display area at right. There are several important
things to know about ArcMap:

e First, associated with ArcMap is a toolbar, which includes such tools as Zoom in, Zoom
out, Pan, Select Elements and Identify.

Zoom Tools
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Zoom Tools Zoom To Full Extent Select Element Find

A toolbar can be moved by grabbing the "perforations"” on the far left, an moving it to
the desired position.. This is an option with all ArcMap toolbars. When you hold the



mouse point over a tool (a graphic icon), a short message called a Tool Tip appearsin a

floating yellow box to tell you the function of the tool.

e Second, ArcMap has two views: Data View and Layout View (the buttons for the two
views are located at the bottom left of the view window). The Data view is for
viewing data, whereas the Layout view is for viewing the map product for printing

and plotting.
|
B | & n
Data Layout Refresh  Pause
e Third, ArcMap VieW  View View Drawing | new project, there

is a default data frame called Layers. Each data frame contains data sets made of
shapefiles, grids, and coverages, and to spatially register them with one another,
these data sets should be based on the same coordinate system. However, ArcMap
has the ability to “reproject on the fly” as long as the coordinate system for the data
has been defined. If one or more of the data sets in a data frame do not have
projection information, ArcMap will display a warning message about the missing
information and use the first available projection information for the display.

e Whenever you work with ArcMap, you are working with a map document. A map
document has the .mxd file extension. This is just a text document that tells the
software what to load.

Connect to Your Exercise Folder r':.+
1. Click on the Connect to Folder icon. Notice that the icon is the same as in e_J
ArcCatalog.

2. Navigate to your Ex_1 folder.

Setting the Workspace

1. In the Geoprocessing Menu select Environments->Workspace
2. Click on the Browse button and connect to your COS120 Ex_1 folder
3. Set both the Current Workspace and the Scratch Workspace to your Ex_1 folder.

This ensures that any new file you create gets saved in that folder and you won't have to "hunt
for it" later. Remember to do this each time you start a new project.

Note: Itis a good habit, to give your project a name and save it as soon as you start.
ArcMap does automatic “saves”, if the software stops working and you have to restart, it
will open to the state of the last save. When you exit ArcMap, it automatically saves the
project. When you reopen the project it will open to where you left off

Explore Feature Layers:
1. From the File menu, save your project with an appropriate name.



2. From the File menu, select Map Document Properties, and put a check mark next to “Store
Relative Pathnames to Data Sources”.

Note: ArcGIS generally provides multiple ways of accomplishing a single task. You will
experience this as we add data to your project.

3. Use the Add Data tool to add the following data sets to your map (you can add them \"}
all at once, by holding down the control key as you select them):

e Penobscot_Towns

e Waterbodies

e Rails

e Streets

e Blocks 2000

4. You can also add data by dragging and dropping from ArcCatalog. Click on the Catalog
tab on the right side. Find the schools layer in ArcCatalog and drag it to the ArcMap
display.

5. From the File menu, select Add Data>Add Data and select the hospitals layer. You
should now have seven layers displayed in ArcMap.

6. ArcMap displays point files on top, line files in the middle, and area/polygon files on the
bottom. The bottom one is drawn first, and the top one is drawn last. You can arrange
the order of the layers by clicking and holding on the data layer and drag it to the place
we want. Verify that the Display tab at the bottom of the TOC is active. v
Drag the rail layer below the street layer. Put the waterbodies below the | &
line features, followed by Penobscot_Towns, then Blocks 2000 on the bottom.
Hospitals should be on top, followed by schools.

7. Click on the check box next to the streets layer. The drawing is turned on when the box
is checked, and off when it is not

Display a Layer Using Its Attributes
1. We want to display the waterbodies in a light blue color with a darker outline.
a. To do this, left-click on the box with filled color to bring up the symbol selector
window
Scroll down to find “Lake Blue”
c. We want to outline the lake with a darker blue.
i. Click on the arrow to the right of the Outline color to reveal more color
choices.
ii. Click on dark blue.
d. Click OK to apply these color changes.
2. Right-click on the symbol for schools.
a. Choose Properties>Symbology.
b. Left-click on the symbol to bring up the Symbol Selector.
c. Click on Style References and place a checkmark on ArcGIS Explorer and click OK.
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d. Now scroll down and search for “School”.
e. Setthe symbol size to 10.
f. Click OK.
3. Click on the hospital symbol and search for hospital.
a. Scroll down to Civic and select Hospital 1
b. Set the size to 10.
4. Make the streets either a dark gray or black.
5. Use the a railroad symbol for rails and use the default color.

We want to display the Penobscot_Towns in a graduated color based on population.

6. Right-click on the Penobscot_Towns layer name and choose properties from the menu.
a. Click the Symbology tab.
b. Inthe box on the left (labeled Show), click Quantities->Graduated Colors.
c. Use the drop-down Value box to choose the field SumPOPOO.
d. Use the Color Ramp drop-down box to choose a greent color ramp. Click OK to
produce the map.
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Identify Geographic Features
1. You can examine a particular feature’s data by using the Identify tool.
2. Use the Zoom in tool and draw a box around some body of water to zoom in on it.
3. Click on the Identify tool open the Identify Results dialog box. Once the Identify
Results dialog box has opened, you can switch layers by from the drop down box.
Change the layer to Penobscot_Towns, and use the Identify tool on the same body of water.
4. Change the layer to Visible layers (these are the layers that are drawn on) and click on the
same body of water.
5. Click on the + sign next to Penobscot_Towns.

o

Ql. Whatis the advantage of choosing All Layers as opposed to a specific layer?

6. Close the Identify Results dialog box.
7. Zoom to full extent.

Finding Geographic Features
The Find tool is a handy way to seek a feature. It will look for features having a specified string
across all of the layers in a map or in an individual layer. It can also search all fields or confine

the
single
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Make sure the Features tab is clicked so that it is active.

Enter the name Pushaw. Choose either All Layers (all layers will be searched) or
waterbodies (only this layer will be searched).

Click Find.

When the feature has been found, choose Pushaw Lake from the list and right-click on its
name and choose Select feature. Note what happens

Right-click again and choose Zoom to feature(s).

Right-click once again and choose Unselect Feature.

Click on the Zoom to Full Extent button to return to the previous extent. O
Experiment with finding a couple of more features. When done, click the Cancel box to
close the Find window.

Experimenting with the Zooming Buttons

1.
2.

Uncheck the streets layer so it will not be visible.

Click the Zoom In tool. Place the cursor in the upper left hand corner of one of the

towns) in Penobscot County (Penobscot_Towns) and click and hold. Continue holding

the mouse button down and drag a box around the town. When finished with the box, let
go of the mouse button.

TIP: If you do not like the area you have chosen, or if you make a mistake,
click the Previous Extent button to return to the original extent. You can use @ Q
the Next Extent to move back the other way.

Click on the corner of the Penobscot_Towns and notice that the view zooms in and

places the point you clicked at the center. The Zoom Out toll works the same way.

Click on the Pan tool, then click and display inside the map window to move the {m}
map around. When you release the mouse button, the map redraws.



5. Click the Zoom Out Center button a few times to zoom out, notice that the center stays put.
6. Click the Zoom In Center button a few times to reverse the process.
7. Zoom to Full Extent.
8. Put a checkmark next to the streets layer so it will be drawn.

Bookmarks
Bookmarks provide a handy way to zoom into extents that you use frequently, or that you want
others to be able to find easily.

Find Bangor in the Penobscot_Towns layer and zoom to the feature.

From the menu bar, select Bookmarks then Create.

Type “Bangor” in the box to name the bookmark.

Return to Full Extent.

From the menu choose Bookmarks->Bangor to use the new bookmark to zoom in.
Use Bookmarks->Manage to examine or remove bookmarks.

ok wnNE

Examine other Attribute Information

1. Right-click on the Penobscot_Towns layer in the TOC, and choose Open Attribute Table.
The attribute table associated with the Penobscot_Towns layer displays. Each record
represents an individual feature in the Penobscot_Towns layer.

Q2. How many records/rows are there in the Penobscot_Towns layer? (Hint: Look at the
bottom of the table window?)

Q3. How many attributes/columns are there in the Penobscot_Town layer?

You can use the Statistics command to calculate basic statistics about all of the records (if none
are selected), or of the selected records.

2. In the table, right-click on the name of the Sum_POPOQO (population in 2000) field and
choose Statistics from the context menu.
3. Examine the statistics and the frequency diagram.

Q4. What was the total population of Penobscot County in 20007?

4. Explore the buttons at the bottom of the attribute table. When finished, close the attribute
table.

5. From the menu bar, choose Selection->Select by Attributes. Use the Query Wizard to
“Create a new selection” on the “Penobscot_Towns” layer. Create the following query:
"NAME" = 'Bangor', by double-clicking “NAME”, single-clicking “=" and double-clicking
“Bangor”. If Bangor is not initially displayed in the list of Penobscot_Towns, click on the
Get Unique Values button. Click OK. The selected Penobscot_Towns is highlighted, but
depending upon where you are zoomed in, it may not be visible.

10
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From the Selection menu, choose Zoom to Selected features, to zoom into Bangor.
6. Open the Attribute table for Penobscot_Towns. At the bottom of the table window, choose
Show Selected. Only the record for Bangor will be displayed.

Q5. What was the population of Bangor in 2000?

7. Return to Full Extent, but leave Bangor selected for the next section.
Select features using spatial relationships (this is a Spatial Query)
We want to select all of the schools within the city of Bangor.
1. From the Selection menu choose Select by Location
a. Select the features of Schools that are completely within the features in the
Penobscot_Towns layer.

11



Q7.

Select features from one or more target layers based on their location in
relation to the features in the source layer.

Selection method:

\select features from

Target layer(s):
[ hospitals point
schools
O rails
[ streets arc
[0 waterbodies polygon
[ blocks_2000 polygon
[ Penobscot_Towns

[Jonly show selectable layers in this list

Source layer:
}0 Penobscot_Towns
Use selected features (1 features selected)

Spatial selection method for target layer feature(s):

’are completely within the source layer feature

Apply a search distance
0.010000 Decimal Degrees

About select by location oK ‘ l Apply l ’ Close

Check the “Use selected features box”.
Click OK.

Open the schools attribute table to see how many were selected.
Click on the Selected button to see just the list of schools that are within Bangor.

How many schools were selected?

Hold the cursor over the icons at the top of the attribute table to find the Clear Selection
icon. Click on it and close the attribute table.

Next select the Blocks_2000 that are contained within Bangor.

Examine the Statistics of the POPOO field of the selected records?

According to this table, what was the population of Bangor in 2000?

12



Q8. Why might the same information in two different tables be different?

Q9. How might you determine which value is the correct one, or if neither is correct?

7. From the Tool Bar, choose Clear Selected features to deselect Bangor and the Blocks it
contains..
8. Zoom to the full extent

Label Map Features and Map Tips.
In this step we will label features on a map and add map tips. A map tip is a way to see
attribute information about a feature when you put a mouse over a feature.
1. Inthe TOC right-click on the Penobscot_Towns and choose Properties to bring up the Layer
Properties dialog box.
2. Click on the Labels tab to set labeling properties.
Check the Label features in this layer box.
4. Click the drop-down list in the Label Field and choose Name, the value we want to use to
label the feature. Set the font size to 14.
5. However, if we label all of the Penobscot_Towns when we are zoomed to full extent, the
map will be unreadable, so we will set the label to only be visible when we zoom in.
a. Click on the Scale Range button to open the Scale Range dialog box
b. Select “Don’t show labels when zoomed”
c. Out beyond 1:500000.
d. Click Ok.
Click OK.
Right-click Penobscot_Towns again and choose Label Features.
Zoom in to the map until the labels appear. L
If the label for Bangor is not visible, it may be necessary to change the color of the labels.
a. Right click on Penobscot_Towns
b. Choose Properties->Labels.
c. Choose a different color for the symbol and click OK.

w
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Q10. What was the scale (to the right of the Add Data button) when they became visible?

10. Zoom back out to full extent.

11. Right-click waterbodies in the TOC and choose Properties. In the Layer Properties dialog Y
box, click the Display tab, then check the box next to Show Map Tips. Click OK.

12. Move your pointer over a lake on the associated map

13. Now that you have added Map Tips, use the Find tool again and Find North Penobscot in
the Penobscot_Towns layer. Once it has been found, right-click on the name. This time
choose Flash feature.

TIP: If the Show Map Tips text is dimmed in the Display Properties menu, then no
spatial index exists for the data layer. Spatial indices must be created in ArcCatalog
before Map Tips can be used.

13




Q9. What do you observe?
14. Close the dialog box.

Scale Range

Scale Range is a layer property that allows additional control of displaying features. You have
already used Scale Range to determine at what scale a label will be visible. You can also specify
a range of map scales at which the map layer is drawn, to avoid cluttering the map with too
much information. Try it with the Streets Layer.

1. Return to Full Extent if necessary.

2. Right-click on the Streets layer name (be sure that it is checked) and choose Properties from
the menu.

3. Click the General tab if it is not already displayed.

4. Fill the button next to “Don’t show layer when zoomed:” and enter the value 120000 in the
box for “out beyond”. Click OK.

5. Notice that the streets have disappeared from the map and the check box next to the layer
has dimmed.

6. Use the Bookmark to zoom in to Bangor and the streets should reappear. If not, use the
Zoom tool to zoom in until they do appear.

7. Return to full extent.

Setting data frame properties

1. Right-click on Layers and choose Properties to bring up the Data Frame Properties dialog
box.

2. Click on the General tab to change the display units. The map units are in decimal degrees,
so change the display units to miles.

3. Also, change the Layer name to Penobscot County.
4. Click OK.
5. Use the Measure tool to find the length of Penobscot County ,f.:?_.:.’,
6. In the Measure dialog box:
a. CI.|ck on the Line button (1st button) and select —— =
Distance e Rl
b. Click on the Choose Units button (4th button) and | |Tomeasure adi [EEESIENE  Kilometers
select Distance->Miles Tomeasweang A2 b Meters
draw a polygon. Decimeters
To measure a feature, dick 'Meast SELINEEE
then dick a feature. ' Millimeters
Nautical Miles

Yards
Feet
Inches

Q11. What is the length (north to south) of Penobscot
County in miles (round to the nearest whole mile?

14
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Double-click to stop measuring.

Creating a Layout
Zoom in to Bangor again.
From the View menu select Layout View. Change the size and placement of the map as you
wish, by selecting it and dragging the handles.
Be sure that your map is selected. From the Insert menu select Neatline and Place around
selected elements
Again from the Insert menu
a. Add alLegend. Do notinclude Blocks_2000 in the Legend, and display your Legend in
2 columns.
Add a Scale bar and North Arrow and an appropriate Title.
Add your name and the date.
d. From the File menu, choose Export Map. Export your map as a jpeg and paste it into
your Report Sheet.

[glen

Your layout should be similar to the following.
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Bangor Maine

0 07515 3 45 6
Miles
Legend for Bangor, Maine
G hospitals point Sum_POP00
& I 40.000000 - 1141.000000 Prepared by:
e l:] Connie Holden
—— rails [ ] 1141.000001 - 2804.000000 September 6, 2015

[ ] waterbodies polygon [ 2804.000001 - 7051.000000

Penobscot_Towns [l 7051.000001 - 11948.000000
I 1948.000001 - 35261.000000

16



